[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Hanging tests mergeinfo-test.exe 12, 15 and skel-test.exe 4 on WinXP with VS2010 release build

From: Johan Corveleyn <jcorvel_at_gmail.com>
Date: Sun, 11 Nov 2012 09:46:00 +0100

On Sat, Nov 10, 2012 at 11:45 PM, Daniel Shahaf <d.s_at_daniel.shahaf.name> wrote:
> Johan Corveleyn wrote on Sat, Nov 10, 2012 at 15:35:21 +0100:
>> On Fri, Nov 9, 2012 at 3:14 AM, Johan Corveleyn <jcorvel_at_gmail.com> wrote:
>>
>> [...]
>>
>> > Now, I have pinpointed the exact revision where the problems start for
>> > me. It's r1338286, where Bert enabled whole program optimizations for
>> > release builds, in the vcnet_vcxproj.ezt file.
>> >
>> > Maybe I'm running into some compiler bug (that has since been fixed in
>> > SP1), related to whole program optimization. I'll try installing SP1
>> > (but not right now, it's past 3 am now :-)) and see what happens.
>>
>> Finally got around to it, and indeed, the problem is solved when I use
>> VC2010 SP1. Test suite is running smoothly, and both
>> mergeinfo-test.exe and skel-test.exe have already succeeded.
>>
>> Now I finally have a good developer environment again, phew.
>>
>> Conclusion: don't use VC2010 without SP1.
>
> Can we make the build scripts trap that condition? (and error out, or
> disable whole-program optimisations)

Good suggestion, but I have no idea really :-). I don't know enough
about the build scripts and project settings, and gen-make stuff etc
...

But maybe someone else here has the expertise to pull this off?

-- 
Johan
Received on 2012-11-11 09:46:58 CET

This is an archived mail posted to the Subversion Dev mailing list.