[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] Make Python 2.5 minimum version for dev tools (including test suite)

From: Hyrum K Wright <hyrum.wright_at_wandisco.com>
Date: Mon, 13 Feb 2012 11:56:26 -0600

On Thu, Feb 9, 2012 at 4:04 PM, Hyrum K Wright
<hyrum.wright_at_wandisco.com> wrote:
> I find myself wanting to use the 'with' statement in the test suite,
> which was introduced in Python 2.5  Python 2.5 was released 5.5 years
> ago, and while I'm sure somebody on some archaic platform somewhere
> doesn't have it installed, I think we can reasonably assume that
> Python 2.5 is generally available.  For reference, we currently
> require and SQLite that is only 2.5-years-old.
>
> (And for the historically minded among us, let's please don't repeat
> the same bikeshed we had when we bumped to Python 2.4 3 years ago:
> http://svn.haxx.se/dev/archive-2009-01/0266.shtml)
>
> I would like to recommend we bump our minimum required version for the
> test suite and development tools to Python 2.5.

The reaction here seems to be a muted "sounds good to me." I've
updated the required files in r1243627.

-Hyrum

-- 
uberSVN: Apache Subversion Made Easy
http://www.uberSVN.com/
Received on 2012-02-13 19:04:29 CET

This is an archived mail posted to the Subversion Dev mailing list.