[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] Make Python 2.5 minimum version for dev tools (including test suite)

From: Daniel Shahaf <danielsh_at_elego.de>
Date: Fri, 10 Feb 2012 00:50:46 +0200

Greg Stein wrote on Thu, Feb 09, 2012 at 17:43:25 -0500:
> On Feb 9, 2012 5:04 PM, "Hyrum K Wright" <hyrum.wright_at_wandisco.com> wrote:
> >
> > I find myself wanting to use the 'with' statement in the test suite,
> > which was introduced in Python 2.5 Python 2.5 was released 5.5 years
> > ago, and while I'm sure somebody on some archaic platform somewhere
> > doesn't have it installed, I think we can reasonably assume that
> > Python 2.5 is generally available. For reference, we currently
> > require and SQLite that is only 2.5-years-old.
> >
> > (And for the historically minded among us, let's please don't repeat
> > the same bikeshed we had when we bumped to Python 2.4 3 years ago:
> > http://svn.haxx.se/dev/archive-2009-01/0266.shtml)
> >
> > I would like to recommend we bump our minimum required version for the
> > test suite and development tools to Python 2.5.
> >
> > Thoughts?
>
> 2.5 is the builtin Python on my Leopard-based Mac laptop. Fine with me, but
> nothing newer for now :-)
>
> Is the version documented anywhere, or just in our community headspace?
>

% fgrep 2.4 * | me
autogen.sh:# that running gen-make.py requires Python 2.4 or newer.
autogen.sh: echo "Python 2.4 or later is required to run autogen.sh"
configure.ac: AC_MSG_WARN([Python 2.4 or later is required to run the testsuite])
INSTALL: 10. Python 2.4 or newer (http://www.python.org/) (OPTIONAL)
INSTALL: Python 2.4 or higher on your system. The majority of the test
INSTALL: * Python 2.4 or higher, downloaded from http://www.python.org/ which is
Makefile.in: echo "make check: Python 2.4 or greater is required,"; \

> Cheers,
> -g
Received on 2012-02-09 23:51:26 CET

This is an archived mail posted to the Subversion Dev mailing list.