[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Subversion working Copy on Substituted Drive

From: Bert Huijben <bert_at_qqmail.nl>
Date: Wed, 25 Jan 2012 11:01:38 +0100

> -----Original Message-----
> From: Karl Heinz Marbaise [mailto:khmarbaise_at_gmx.de]
> Sent: woensdag 25 januari 2012 10:44
> To: dev_at_subversion.apache.org
> Subject: Re: Subversion working Copy on Substituted Drive
>
> Hi,
>
> after a good hint via IRC now a original failure message:
>
> Sending X://test.txt
> Transmitting file data .svn: Commit succeeded, but other errors follow:
> svn: Error bumpung revision post-commit (details follow):
> svn: In Directory 'X:'
> svn: Log entry missing 'name' attribute (entry 'rm' for directory 'X:').

Subversion <= 1.6 doesn't work stable in the root of drives, only in
subdirectories. Some commands worked, and some didn't. Your subst triggers
this problem.

This was fixed in Subversion 1.7, but the changes were to invasive to
backport.
(This specific error message was removed in 1.7, as it is specific to the
old 'loggy' infrastructure)

        Bert
>
> Kind regards
> Karl Heinz Marbaise
> --
> SoftwareEntwicklung Beratung Schulung Tel.: +49 (0) 2405 / 415 893
> Dipl.Ing.(FH) Karl Heinz Marbaise ICQ#: 135949029
> Hauptstrasse 177 USt.IdNr: DE191347579
> 52146 Würselen http://www.soebes.de
Received on 2012-01-25 11:03:01 CET

This is an archived mail posted to the Subversion Dev mailing list.