[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Looks like wrong value for SVN_VER_REVISION in SWIG bindings for Python and Ruby?

From: Daniel Shahaf <danielsh_at_elego.de>
Date: Wed, 07 Dec 2011 19:56:08 +0200

On Wed, Dec 7, 2011, at 19:53, Daniel Shahaf wrote:
> On Wed, Dec 7, 2011, at 11:43, Hyrum K Wright wrote:
> > On Wed, Dec 7, 2011 at 11:29 AM, Stefan Sperling <stsp_at_elego.de> wrote:
> > > On Wed, Dec 07, 2011 at 11:23:30AM -0400, Shane Turner wrote:
> > >> Should I open a bug report to have the packages regenerated,
> > >
> > > No. Releases are never regenerated. That would invalidate signatures
> > > developers sent for the release.[*]
> > >
> > > We'll have to figure out the source of the problem and then try
> > > to avoid it in future releases.
> >
> > It may be related to the sed problem we were having in the 1.7 RC
> > series. Apparently one of scripts relied upon GNU sed which wasn't
> > installed on people.apache.org. I had been using a custom install of
> > it, but I thought Daniel had fixed the offending script to not require
> > GNU sed. 1.7.2 represents the first release in which I relied upon
> > the system sed, and not my custom one.
> >
>
> r1159741
>
> However, SVN_VER_REVISION on the 1.7.2 tag is wrong.

... but SVN_VER_TAG, which incorporates the revnum, is right.

Hmm.
Received on 2011-12-07 18:56:39 CET

This is an archived mail posted to the Subversion Dev mailing list.