[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: mod_dav_svn.so causes a Fatal Bug in Apache 2.2.21 with SVN v1.7.0 or v1.7.1

From: Mark Phippard <markphip_at_gmail.com>
Date: Wed, 26 Oct 2011 14:01:09 -0400

This is in the proposals for backports to 1.7.x branch:

 * r1187695
   Have mod_dav_svn ignore non-Subversion POST requests.
   Justification:
     mod_dav_svn does not play well with others.
   Votes:
     +1: philip, rhuijben

2011/10/24 DarkStone <darkstone_at_163.com>:
> Hi there :)
>
> Below is my info:
>
> Operating system: Windows 7 Ultimate x86
> The release of Subversion: v1.7.0 and v1.7.1 Binary Version
> The release of Apache: v2.2.21
>
>
> The Fatal Bug I've Found:
>
> When I've setup Apache 2.2.21 with SVN v1.7.0, Apache and SVN works fine,
> except one thing:
>
> When I request an XML file using HTTP POST, Apache gives me HTTP 500
> Internal Error
> But if I request that same XML file using HTTP GET, it works just fine
>
> Here is the access.log
>
> ::1 - - [24/Oct/2011:23:54:17 +0800] "POST /data/VideoMenuBar.xml HTTP/1.1"
> 500 537
> ::1 - - [24/Oct/2011:23:54:06 +0800] "GET /data/VideoMenuBar.xml HTTP/1.1"
> 200 3695
>
> Note that this bug hap pens every time and affecting all XML file requests
> using HTTP POST!
>
> And later I tested Apache 2.2.21 with SVN v1.7.1,  it got the same bug
>
>
> After many testings I finally locate the problem:
>
> mod_dav_svn.so (from Subversion v1.7.0 and v1.7.1 windows binary)
>
> Yes, the bug is causing by mod_dav_svn.so
>
> Why am I so positive about this?
>
> 'cuz when I remove this line from httpd.conf:
>
> LoadModule dav_svn_module modules/mod_dav_svn.so
>
> and restart Apache Service, I can request any XML file using HTTP POST or
> GET with no problems!
>
>
> Later I've tested Apache 2.2.21 + SVN 1.6.17, it does not have this bug
>
> Which means mod_dav_svn.so from Subversion v1.6.17 works perfectly
>
>
>
> I'm from China, thanks for bearing with my bad English, I wish you get the
> point and fix this bug asap.
>
> Keep going on your great work!
>
>
>
> DarkStone
> 2011-10-25
>
>
>

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
Received on 2011-10-26 20:01:42 CEST

This is an archived mail posted to the Subversion Dev mailing list.