[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] fix build failure when configured using --without-zlib

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Fri, 23 Sep 2011 16:49:50 +0300

Applied, with a new log message.

Alexander Thomas wrote on Fri, Sep 23, 2011 at 18:09:53 +0530:
> All,
>
> AFAIK, Subversion cannot be build without zlib. At present if configured
> using '--without-zlib' or '--with-zlib=no' options, build will fail with
> following error message ...
> [[[
> Subversion/trunk/libtool: line 4992: cd: no/lib: No such file or
> directory
> libtool: link: cannot determine absolute directory name of `no/lib'
> ]]]
>
> [[[
> Fixes build failure when configured with '--without-zlib'.
>
> * build/ac-macros/zlib.m4
> (SVN_LIB_Z): Configure error-outs if executed with '--without-zlib'
> or '--with-zlib=no' options.
>
> Patch by: Alexander Thomas <alexander_at_collab.net>
> ]]]
>
>
> -Alexander Thomas(AT)

> Index: build/ac-macros/zlib.m4
> ===================================================================
> --- build/ac-macros/zlib.m4 (revision 1174526)
> +++ build/ac-macros/zlib.m4 (working copy)
> @@ -32,6 +32,8 @@ AC_DEFUN(SVN_LIB_Z,
> [
> if test "$withval" = "yes" ; then
> AC_MSG_ERROR([--with-zlib requires an argument.])
> + elif test "$withval" = "no" ; then
> + AC_MSG_ERROR([cannot compile without zlib.])
> else
> AC_MSG_NOTICE([zlib library configuration])
> zlib_prefix=$withval
Received on 2011-09-23 15:51:10 CEST

This is an archived mail posted to the Subversion Dev mailing list.