[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn_error_t *make_foo(svn_foo_t **foo_p, apr_pool_t *result, apr_pool_t *scratch);

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Tue, 13 Sep 2011 20:44:38 +0300

Stefan Sperling wrote on Tue, Sep 13, 2011 at 19:31:30 +0200:
> On Tue, Sep 13, 2011 at 09:39:11AM -0500, Hyrum K Wright wrote:
> > On Tue, Sep 13, 2011 at 9:02 AM, C. Michael Pilato <cmpilato_at_collab.net> wrote:
> > > On 09/12/2011 09:12 PM, Daniel Shahaf wrote:
> > >> [RFC] In new code, rename RESULT_POOL and SCRATCH_POOL to RESULT and
> > >> SCRATCH, respectively.
> > >>
> > >> Because the names are too long and C is strongly typed.
> > >
> > > Meh.
> > >
> > > Or, to be more formal about it: -0.
> >
> > Maybe I'm just getting crotchety in my old age, but I'm also -0 on
> > this proposal.
>
> Me too. Let's keep the names as they are.
>

Okay.

> Changing this convention would also introduce naming inconsistencies
> we'd have to fix up at some point, for no real gain whatsoever.

If inconsistencies had been the issue I would have offered to rename the
variables throughout the tree.
Received on 2011-09-13 19:45:24 CEST

This is an archived mail posted to the Subversion Dev mailing list.