[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.7.0 upgrade doesn't properly follow svn:externals

From: Scott Palmer <scott.palmer_at_digitalrapids.com>
Date: Fri, 9 Sep 2011 18:15:46 +0000

On 2011-09-09, at 11:59 AM, Neels J Hofmeyr wrote:

> On 09/09/2011 05:25 PM, Scott Palmer wrote:
>> Btw, I haven't had a chance to go back to 1.6 to test - is the issue with svn:externals referencing a file fixed? It used to add the file as both an external and a regular file so it was conflicting with itself.
>>
>> Scott
>
> Are you referring to issue #4000?
> http://subversion.tigris.org/issues/show_bug.cgi?id=4000
>
> If not, do you have a link or a reproduction script?
>
> Thanks,
> ~Neels

It may be related, and possibly it fixes the issue I encountered, but it is not exactly the same. What happened in my case is that a file external was in my 1.6 working copy and the svn upgrade appeared to add it as a "first-class node" while leaving it as an external as well. From that point on "svn update" would complain about overwriting the first-class node when attempting to update the external reference.

Sorry I don't have a reproduction script - I'm not currently set up to run both 1.6 and 1.7 to build one.

I suppose you can start with the first part of the script in issue #4000 but use svn 1.6 up to the point of creating the wWC with the file external and checking it out. Then just switch to 1.7 and attempt an upgrade and update.

Scott
Received on 2011-09-09 23:25:47 CEST

This is an archived mail posted to the Subversion Dev mailing list.