[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: lock_tests.py failing over ra-svn

From: Stephen Butler <sbutler_at_elego.de>
Date: Thu, 1 Sep 2011 09:40:10 +0200

On Aug 31, 2011, at 23:47 , Stefan Sperling wrote:

> On Wed, Aug 31, 2011 at 10:35:00PM +0200, Stephen Butler wrote:
>> Hi folks,
>>
>> Is anyone else seeing the following test failures on trunk?
>>
>> At least one test FAILED, checking /Users/steve/dev/unix-build/svn-trunk/tests.log
>> FAIL: lock_tests.py 10: verify svn:needs-lock behavior with defunct lock
>> FAIL: lock_tests.py 15: verify status of stolen lock
>> FAIL: lock_tests.py 28: verify info path_at_X or path -rY return repos lock
>> FAIL: lock_tests.py 32: verify unlocking with wrong lock token
>> Summary of test results:
>> 39 tests PASSED
>> 4 tests FAILED
>>
>> In each case (details below) information about a stolen lock is
>> not received by the client.
>>
>> I'm on OS X 10.6.8, developer tools 3.2.5. I don't see any
>> failures over ra-local, serf, or neon. Over ra-svn they're
>> reproducible. I don't know if this is a Mac issue, since the
>> buildbot doesn't include tests on OS X.
>
> Do you see these with 1.7.x, too?
>
> (Please say "no" ;)

No. I mean, really no. ;) There were no failures when I tested 1.7.0-rc2
last week (after I resolved some build problems on my laptop, which took
a while.)

Steve

--
Stephen Butler | Senior Consultant
elego Software Solutions GmbH
Gustav-Meyer-Allee 25 | 13355 Berlin | Germany
tel: +49 30 2345 8696 | mobile: +49 163 25 45 015
fax: +49 30 2345 8695 | http://www.elegosoft.com
Geschäftsführer: Olaf Wagner | Sitz der Gesellschaft: Berlin
Amtsgericht Charlottenburg HRB 77719 | USt-IdNr: DE163214194
Received on 2011-09-01 09:39:35 CEST

This is an archived mail posted to the Subversion Dev mailing list.