[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

API review - svn_checksum, svn_client

From: Julian Foad <julian.foad_at_wandisco.com>
Date: Fri, 03 Jun 2011 18:33:00 +0100


  svn_auth.h - no comments
  svn_base64.h - no comments
  svn_client.h (except group 'Patch')


  * svn_checksum_mismatch_err() - Private? Doesn't say how the formatted
string is combined with some generic description of the mismatch.

  * svn_client_commit5() - better name and/or description for
'commit_as_operations' param?

  * svn_client_upgrade() - What versions can it upgrade from and to?
What upgrade-specific error conditions can it encounter? Document the
'dir' parameter: e.g. does it need to be the root of a WC?

  * svn_client_info3() - doc says 'path_or_url', param name is
'abspath_or_url'; which is intended?

  * svn_client_uuid_from_path2() - since this now requires an abspath,
maybe rename to ..._from_abspath()? Or keep accepting a relative path.
Seems a bit arbitrary for these two libsvn_client APIs (this and info3)
to switch to requiring an abspath. Maybe they should continue to accept
local paths relative to the current working dir, for API consistency?


  * svn_client_commit_item3_t.session_relpath - New field; insufficient

  * svn_info_t has grown a 'wcroot_abspath' field even though the
structure is being deprecated and replaced by svn_info2_t. Intentional?

- Julian
Received on 2011-06-03 19:33:37 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.