[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r1103177 - in /subversion/trunk/subversion/libsvn_wc: wc-queries.sql wc_db.c

From: Greg Stein <gstein_at_gmail.com>
Date: Sat, 14 May 2011 15:29:53 -0400

On Sat, May 14, 2011 at 14:19, <hwright_at_apache.org> wrote:
>...
> +++ subversion/trunk/subversion/libsvn_wc/wc_db.c Sat May 14 18:19:11 2011
> @@ -2466,10 +2466,18 @@ run_final_query(void *baton,
>                 svn_wc__db_wcroot_t *wcroot,
>                 apr_pool_t *scratch_pool)
>  {
> -  int *finalize_idx = baton;
> +  int *final_queries = baton;
> +  int *query_idx = final_queries;

Seems that 'final_queries' is not needed.

>...
> +  struct set_changelist_baton_t scb = { new_changelist, changelist_filter,
> +                                        depth };
> +  int final_queries[] = { STMT_DROP_CHANGELIST_LIST, STMT_DROP_TARGETS_LIST,
> +                          -1 };

It seems that it would be cleaner to just put the 'DROP TABLE
targets_list' into the STMT_DROP_CHANGELIST_LIST (maybe rename the
latter to something like STMT_FINALIZE_CHANGELIST). Then you could rip
out all this multiple statement stuff. I think one STMT would be
cleaner than all this code to support multiple.

>...

Cheers,
-g
Received on 2011-05-14 21:30:22 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.