[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Performance benchmarks-1.5 results show significant regression in 1.6

From: Stefan Sperling <stsp_at_elego.de>
Date: Thu, 31 Mar 2011 19:11:12 +0200

On Thu, Mar 31, 2011 at 01:04:20PM -0400, Mark Phippard wrote:
> On Thu, Mar 31, 2011 at 1:01 PM, Stefan Sperling <stsp_at_elego.de> wrote:
>
> >> Yes, I believe so.  That was also the thread on users@ that made me
> >> add this scenario into these benchmarks.
> >
> > Mark, can you run the tests with this branch?
> > ^/subversion/branches/1.6.x-issue3719
> > Maybe it helps.
>
> I am not the one that ran these tests.

Someone with a windows system should run them, then.
I don't have such a system.

> 1.7 shows some improvement but
> it is not back to the 1.5.x level.

Well, 1.7 already has the issue #3719 fix. But 1.6.x does not.

Finding out whether or not the issue #3719 problem contributes
most to the time spent during checkout in 1.6.x would already
give us valuable information.

> > Also, does this problem show on non-Windows systems?
>
> No one has submitted results from 1.5 or earlier on any other OS. We
> would need someone to run the tests using 1.5 and 1.6 to see if it
> shows up. You can edit the svn.properties file to only run the
> Binaries tests as that is there this problem shows.

If it only shows for binary files it's quite likely to be issue #3719
since it hurts most when you have lots of files with properties in
some directory.
Received on 2011-03-31 19:11:46 CEST

This is an archived mail posted to the Subversion Dev mailing list.