[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Setting up svnserver with SASL

From: Robert Schwalbe <roberts_at_inode.com>
Date: Sat, 26 Mar 2011 12:01:38 -0400

I cross posted this message this past week to users_at_subversion.apache.org without it garnering any attention. Please have some leniency to the cross posting - I'm hoping the technical knowledge of this membership might prove more insightful.

--
I'm attempting to setup svnserver with SASL on Mac OS X Server 10.6.6 per the documentation at:
   http://svnbook.red-bean.com/nightly/en/svn.serverconfig.svnserve.html#svn.serverconfig.svnserve.sasl
I guess I would like to start by simply asking if any one has successfully done so.
Currently I'm stumped when using saslpasswd2.  I get prompted for the password, and prompted for verification, but the sasldb does not get created (or at least I cannot find it).
Arek Dreyer pointed out the following:
   syslog -w shows:
   saslpasswd2[11095] <Error>: auxpropfunc error no mechanism available
   saslpasswd2[11095] <Debug>: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: pwauxprop
   saslpasswd2[11095] <Notice>: setpass succeeded for somename
   saslpasswd2[11095] <Debug>: Setpass for OTP successful
   saslpasswd2[11095] <Notice>: OTP: set secret for somename
Any help, pointers, suggestions or (even) snide comments would be sincerely appreciated.
Received on 2011-03-26 17:02:12 CET

This is an archived mail posted to the Subversion Dev mailing list.