[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Need help with Makefile.svn

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Sat, 19 Mar 2011 17:51:34 +0200

Daniel Shahaf wrote on Sat, Mar 19, 2011 at 17:33:23 +0200:
> Stefan Sperling wrote on Sat, Mar 19, 2011 at 13:56:45 +0100:
> > On Sat, Mar 19, 2011 at 06:13:37PM +0530, Vignesh Srinivasan wrote:
> > > Hi
> > >
> > > I am newbie to subversion development trying to learn and contribute to the
> > > community. Sorry if this is numb question.
> > >
> > > I am trying to setup the development environment using Makefile.svn and I am
> > > stuck with the bellow error. Could someone help me in proceeding further?
> > >
> > > if [ "none" = "none" ]; then \
> > > echo "SWIG disabled at configure time" >&2; \
> > > exit 1; \
> > > fi
> > > SWIG disabled at configure time
> > > make[1]: *** [check-SWIG] Error 1
> > > make[1]: Leaving directory `/home/vignesh/src/svn/subversion/svn-trunk'
> > > make: ***
> > > [/home/vignesh/src/svn/subversion/objdir/svn-trunk/.bindings-compiled] Error
> > > 2
> > >
> >
> > Hi Vignesh,
> >
> > you need to install swig.
> >
>
> Or just don't pass --with-swig to configure.

I meant: don't run 'make swig-py' or 'make check-swig-py'. (Apparently
the Makefile.svn wrapper does this for you.)

> It's only required for the py/pl bindings.
Received on 2011-03-19 16:57:06 CET

This is an archived mail posted to the Subversion Dev mailing list.