[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r1078008 - /subversion/trunk/subversion/libsvn_wc/wc_db.c

From: Greg Stein <gstein_at_gmail.com>
Date: Fri, 4 Mar 2011 11:25:58 -0500

On Fri, Mar 4, 2011 at 11:19, Hyrum K Wright <hyrum_at_hyrumwright.org> wrote:
> 2011/3/4 Branko Čibej <brane_at_e-reka.si>:
>> On 04.03.2011 16:33, hwright_at_apache.org wrote:
>>> Author: hwright
>>> Date: Fri Mar  4 15:33:48 2011
>>> New Revision: 1078008
>>>
>>>
>>> -  scb.changelist = changelist;
>>> -
>>> -  SVN_ERR(with_db_txn(wcroot, local_relpath, set_changelist_txn, &scb,
>>> -                      scratch_pool));
>>> +  SVN_ERR(with_db_txn(wcroot, local_relpath, set_changelist_txn,
>>> +                      (void *) changelist, scratch_pool));
>>
>> This is not casting const away. This is changing the type. I know it's a
>> nitpick, but strictly speaking, your log message is wrong.
>
> At the risk of building a bikeshed of epic proportions, which
> construct would be favored in this case (char *) or (void *)?

(void *) ... if we're going to have an explicit cast, then may as well
make it the target (rather than one explicit plus one implicit).

Cheers,
-g
Received on 2011-03-04 17:26:29 CET

This is an archived mail posted to the Subversion Dev mailing list.