[PATCH] Renames functions in libsvn_repos/authz.c with better meaning
There are a couple of functions (authz_get_global_access,
authz_global_parse_section) inside libsvn_repos/authz.c which completely
threw me off track by virtue of their names. The names seem to suggest
that they check for global access to the repository, which is very
misleading. What they actually do is check to see if the user has *any*
kind of access to *any* part of the repository.
This patch renames these functions to convey a better meaning, and also
inserts a comment that explains the function better. I have attached the
patch and log message.
Received on 2011-01-19 14:48:53 CET
This is an archived mail posted to the Subversion Dev