[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[ANN ] SVNKit 1.3.5 is available.

From: Alexander Kitaev <Alexander.Kitaev_at_svnkit.com>
Date: Fri, 14 Jan 2011 19:45:45 +0100

Hello All,

We are glad to announce that SVNKit 1.3.5 has been published and
available for download at http://svnkit.com/ web site.

SVNKit is a pure Java Subversion library. SVNKit provides Java APIs to
access and manipulate Subversion working copies and Subversion
repositories. You may find more information, documentation and source
code examples at http://svnkit.com/

SVNKit 1.3.5 supports mostly all Subversion 1.6.15 features. Also, we
made sure that all native Subversion tests pass when ran against SVNKit
and that is more than 2500 tests in total.

New in version 1.3.5 (since version 1.3.4):

+ Changes made in Subversion since version 1.6.12 implemented,
   all of the major Subversion 1.6.15 features are supported.
+ Support for OS X Keychain as credentials storage added.
+ SSL client certificate passphrase is cached in a way
   compatible with that of the native Subversion.
+ HTTP cookies are handled properly.
+ SQLJet library upgraded to v1.0.4
+ Other minor bugfixes and improvements.

You're welcome to download and use SVNKit 1.3.5. We'll be glad to
provide help and support for the new version in our mailing list or by
email (support_at_svnkit.com).

Useful links (more at http://svnkit.com/):

* SVNKit Continuous Integration Server: https://teamcity.svnkit.com/
* SVNKit Source Code Repository: http://svn.svnkit.com/repos/svnkit/
* SVNKit Update Site (for Eclipse): http://eclipse.svnkit.com/1.3.x/
* SVNKit Mailing List: http://www.nabble.com/SVNKit---Users-f18684.html

Note for Eclipse (Subclipse) users:

Those of you who use SVNKit 1.3.5 as an Eclipse plug-in (e.g. Subclipse
1.6.x users) are strongly advised to update SVNKit with the help of
SVNKit update site: http://eclipse.svnkit.com/1.3.x/

SVNKit consists of two plug-ins - Core SVNKit and JNA Library, we
recommend to install both plug-ins. SVNKit plug-ins are OSGI-compatible.

The best available version of SVNKit is 1.3.5.7406 (that is 1.3.5 GA).

With best regards,
SVNKit Development Team.

-- 
Alexander Kitaev,
TMate Software,
http://svnkit.com/ - Java [Sub]Versioning Library!
http://sqljet.com/ - Java SQLite Library!
Received on 2011-01-14 19:46:26 CET

This is an archived mail posted to the Subversion Dev mailing list.