Re: [PATCH] Bug in svn_fs_paths_changed2() Python bindings?
On Wednesday, August 11, 2010 12:10:41 pm C. Michael Pilato wrote:
> On 08/10/2010 09:22 PM, Alexey Neyman wrote:
> > Okay, try again:
> > [[[
> > Fix the type of structures returned in bindings from
> > svn_fs_paths_changed2().
> > * subversion/include/svn_fs.h
> > (svn_fs_paths_changed2): Rename the argument from changed_paths_p to
> > changed_paths_p2, so that it's different from argument to
> > svn_fs_paths_changed().
> Minor nit -- I think 'changed_paths2_p' would be a better name. To me, a
> number at the very end of a parameter name says "differentiator" (as in
> 'strcmp(str1, str2)') whereas having that '2' closer to the 'changed_paths'
> name says "version iterator". But like I said, it's a minor nit.
> Otherwise, +1 on the patch.
Agreed. Updated patch attached.
Received on 2010-08-11 22:13:09 CEST
This is an archived mail posted to the Subversion Dev