[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r980139 - in /subversion/trunk/subversion: include/svn_dirent_uri.h libsvn_subr/dirent_uri.c

From: C. Michael Pilato <cmpilato_at_collab.net>
Date: Thu, 29 Jul 2010 09:33:58 -0400

On 07/28/2010 01:51 PM, julianfoad_at_apache.org wrote:
> Author: julianfoad
> Date: Wed Jul 28 17:51:10 2010
> New Revision: 980139
> URL: http://svn.apache.org/viewvc?rev=980139&view=rev
> Log:
> Rename some function parameters for clarity: where "xxx1" and "xxx2"
> represent two paths in a parent-child relationship, rename them to
> "parent_xxx" and "child_xxx" respectively.

There's a part of me that groans a little bit here because in having
parameters named parent_path and child_path, you're almost dictating that
relationship to the callers. That's all wrong, though, because in many of
these cases, the functions are asking questions of that very relationship.
("Is CHILD_PATH really a child path of PARENT_PATH?").

That said, for years now I've been far more irritated by the fact that I
have to read the docstring for those is-child type functions just to
remember which of PATH1 and PATH2 is which. So...

                           T H A N K Y O U !

C. Michael Pilato <cmpilato_at_collab.net>
CollabNet   <>   www.collab.net   <>   Distributed Development On Demand

Received on 2010-07-29 15:34:44 CEST

This is an archived mail posted to the Subversion Dev mailing list.