> -----Original Message-----
> From: Ramkumar Ramachandra [mailto:artagnon_at_gmail.com]
> Sent: maandag 26 juli 2010 14:13
> To: Subversion-dev Mailing List
> Subject: Proposal: Rename svnrdump
> I've started working on load support too, and `svnrdump load` can be
> quite misleading- should we rename the tool? I'm floating this thread
> early so that we can minimize code churn due to the rename (in tests
> for example).
Last Saturday on IRC, I suggested 'svnradmin', but this can be misleading
too, as users might expect it do everything 'svnadmin' can, which is clearly
impossible for security reasons.
(A much older suggestion was moving the code into svnsync as they are
But I'm fine with just keeping 'svnrdump' even for loading. It just uses
'dump' for referring that it processes dumpfiles (like svndumpfilter does),
instead of to just dumping the repository.
Received on 2010-07-26 15:20:36 CEST