[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Move of a new folder with renamed file causes "The node was not found"

From: Philip Martin <philip.martin_at_wandisco.com>
Date: Mon, 12 Jul 2010 10:02:26 +0100

"Bert Huijben" <bert_at_vmoo.com> writes:

>> -----Original Message-----
>> From: Onno van der Straaten [mailto:onno.van.der.straaten_at_gmail.com]
>> Sent: maandag 12 juli 2010 10:10
>> To: dev_at_subversion.apache.org; philip.martin_at_wandisco.com;
>> stsp_at_elego.de
>> Subject: Re: Move of a new folder with renamed file causes "The node was
>> not found"
>>
>> Hi Stefan, Philip,
>> I have created a unit test "move_new_folder_with_moved_file" to cover
>> this case. I added it to copy_tests.py at line 2210. When I run this
>> test it fails but with a different message which I think could also
>> indicate a bug. The message is svn: '/A/B2/new' is out of date.
>>
>> Can you confirm this is a bug and that the unit test is correct?
>> Complete output of the test is added below.

Please send diffs, not complete files.

> Can you test this with a build after r962553, in which Philip fixed a few
> more copy/move cases.

I fixed some bugs, but I still have at least one scenario that fails.

> Note that current trunk version of WC-NG can't express all copy/move
> operations that 1.6.x could, until the so called '4-th tree' is implemented.

The limitation that I know about is that some of the replacements
cannot be reverted. This is a regression w.r.t. 1.6 but I don't think
it prevents the replace being made or committed.

-- 
Philip
Received on 2010-07-12 11:29:59 CEST

This is an archived mail posted to the Subversion Dev mailing list.