Re: svn commit: r955136 - in /subversion/trunk/subversion: include/ libsvn_fs/ libsvn_fs_base/ libsvn_fs_fs/ tests/libsvn_fs/
Philip Martin wrote:
> danielsh_at_apache.org writes:
>> Author: danielsh
>> Date: Wed Jun 16 06:05:17 2010
>> New Revision: 955136
>> URL: http://svn.apache.org/viewvc?rev=955136&view=rev
>> Revv the FS change_rev_prop() interface towards more atomicity.
>> Suggested by: philip
>> * subversion/include/svn_fs.h
>> (svn_fs_change_rev_prop2): New, takes OLD_VALUE_P parameter.
>> (svn_fs_change_rev_prop): Deprecate.
> I don't think the old interface should be deprecated.
If the old interface is not to be deprecated, then please don't use our
simple numeric interface revision naming scheme. Give the thing a new name,
such as svn_fs_change_matching_rev_prop() or somesuch.
C. Michael Pilato <cmpilato_at_collab.net>
CollabNet <> www.collab.net <> Distributed Development On Demand
Received on 2010-06-16 15:31:24 CEST
This is an archived mail posted to the Subversion Dev