[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Fixing prop_tests.py failure in Solaris

From: Stefan Sperling <stsp_at_elego.de>
Date: Wed, 9 Jun 2010 13:31:54 +0200

On Wed, Jun 09, 2010 at 12:15:58PM +0100, Philip Martin wrote:
> Stefan Sperling <stsp_at_elego.de> writes:
>
> > On Wed, Jun 09, 2010 at 12:36:31PM +0200, Stefan Sperling wrote:
> >> It would be great if you could build with --enable-maintainer-mode and
> >> show the error trace of the failing test. An easy way is to just post
> >> the entire output of ./prop_tests.py --verbose invalid_propnames
> >
> > It turns out that the same problem exists on my system (OpenBSD).
> >
> > Is anyone else seeing this? Is it new?
>
> [...]
>
> > CMD: svn propdel " --config-dir /home/stsp/svn/svn-trunk/subversion/tests/cmdline/svn-test-work/local_tmp/config --password rayjandom --no-auth-cache --username jrandom
> > CMD: /home/stsp/svn/svn-trunk/subversion/svn/svn propdel --config-dir /home/stsp/svn/svn-trunk/subversion/tests/cmdline/svn-test-work/local_tmp/config --password rayjandom --no-auth-cache --username jrandom exited with 1
> > <TIME = 0.590402>
> > subversion/svn/propdel-cmd.c:79: (apr_err=22)
> > subversion/libsvn_subr/utf.c:729: (apr_err=22)
> > subversion/libsvn_subr/utf.c:711: (apr_err=22)
> > subversion/libsvn_subr/utf.c:558: (apr_err=22)
> > svn: Non-ASCII character (code 8) detected, and unable to convert to/from UTF-8
> > EXPECTED STDERR (regexp):
> > .*Attempting to delete nonexistent property '.*
> > ACTUAL STDERR:
> > subversion/svn/propdel-cmd.c:79: (apr_err=22)
> > subversion/libsvn_subr/utf.c:729: (apr_err=22)
> > subversion/libsvn_subr/utf.c:711: (apr_err=22)
> > subversion/libsvn_subr/utf.c:558: (apr_err=22)
> > svn: Non-ASCII character (code 8) detected, and unable to convert to/from UTF-8
> > EXCEPTION: SVNUnmatchedError
>
> [...]
>
> > FAIL: prop_tests.py 22: test prop* handle invalid property names
>
> It works on my Linux box using r952912:
>
> CMD: svn propdel " --config-dir /home/pm/sw/subversion/obj2/subversion/tests/cmdline/svn-test-work/local_tmp/config --password rayjandom --no-auth-cache --username jrandom
> CMD: /home/pm/sw/subversion/obj2/subversion/svn/svn propdel --config-dir /home/pm/sw/subversion/obj2/subversion/tests/cmdline/svn-test-work/local_tmp/config --password rayjandom --no-auth-cache --username jrandom exited with 1
> <TIME = 0.045972>
> ../src2/subversion/svn/propdel-cmd.c:151: (apr_err=195011)
> svn: Attempting to delete nonexistent property '
>
> [...]
>
> PASS: prop_tests.py 22: test prop* handle invalid property names
 
Hmmm... I will try to debug this during the hackathon.

Stefan
Received on 2010-06-09 13:32:41 CEST

This is an archived mail posted to the Subversion Dev mailing list.