[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r943219 - /subversion/trunk/subversion/libsvn_wc/update_editor.c

From: Greg Stein <gstein_at_gmail.com>
Date: Thu, 13 May 2010 12:04:22 -0400

On Thu, May 13, 2010 at 08:53, Julian Foad <julian.foad_at_wandisco.com> wrote:
>...
> I was trying to do two things: avoid using plain "base" because in
> traditional usage (which is still widespread) it means "WORKING_NODE if
> present else BASE_NODE"; and also identify that it refers to the *text*
> of the BASE_NODE rather than, say, its properties.
>
> Thinking about this now, "text" would be better than "pristine", so I

hmm? "pristine" has a specific meaning in wc_db. Are you proposing to
change that? Or is this somehow a different concept?

> propose "get_base_text_{checksum,path}", or even
> "get_base_node_text_{checksum,path}".
>
> Actually I intend to replace these local functions with one or more
> library-scope functions, perhaps like
>
>  svn_wc__get_base_node_text_info(OUT abspath,
>                                  OUT sha1_checksum,
>                                  OUT md5_checksum,
>                                  OUT file_size,
>                                  IN db, local_abspath, pools);
>
> where the OUT params are optional outputs.  Any comments on that?

What's the abspath for? The location in the pristine database? We
really don't want to throw that around the library. That got us into
trouble, and we don't want to go back there It is best to stick to
readonly streams.

What's the "file_size" ... is that "translated_size"? If so, then use
that name. (stop changing names!)

If the translated_size is in this API, then why not last_mod_time?

How is this function different from svn_wc__db_base_get_info() ? Why
not just use that function?

Cheers,
-g
Received on 2010-05-13 18:04:59 CEST

This is an archived mail posted to the Subversion Dev mailing list.