[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Paths in the client patch code

From: Hyrum K. Wright <hyrum_wright_at_mail.utexas.edu>
Date: Tue, 4 May 2010 11:30:07 +0200

On Tue, May 4, 2010 at 11:13 AM, Stefan Sperling <stsp_at_elego.de> wrote:

> On Tue, May 04, 2010 at 10:54:51AM +0200, Hyrum K. Wright wrote:
> > I see a lot of paths in the client patch code, but few of the variable
> names
> > are explicit about whether the path is absolute or relative. Can
> somebody
> > who knows the code comment on what types of paths it uses? If we do
> know,
> > we should probably rename the various patch variables as foo_abspath or
> > foo_relpath, as the circumstance may dictate.
> Can you be more specific and list the variables which are unclear to you?
> Then I'll try finding better names for them.

In particular, the patched_path, reject_path members of the patch_target_t
struct. But more generally, most variables that end in _path, shouldn't.

Received on 2010-05-04 11:30:41 CEST

This is an archived mail posted to the Subversion Dev mailing list.