[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Rename text-base variables in update-editor.c

From: Greg Stein <gstein_at_gmail.com>
Date: Wed, 7 Apr 2010 18:44:19 -0400

On Wed, Apr 7, 2010 at 18:27, Julian Foad <julian.foad_at_wandisco.com> wrote:
> Greg Stein wrote:
>> Why do some names use text_base and others use pristine? Aren't those
>> the same thing?
> The ones using 'pristine' are the ones added by Hyrum's SVN_EXPERIMENTAL
> code, which, for the moment, run in parallel with the old ones, and then
> later will replace the old ones.  I haven't settled on which name is
> more suitable for the final version, but it should be just one not a
> mixture of both.  At the moment, the names occur in pairs like these:
>  { text_base_abspath, pristine_abspath } are the paths to two separate
> copies of the same content;
>  { text_base_checksum_md5, pristine_checksum_sha1 } are two different
> kinds of checksum for the same content; we will probably need to keep
> both of them.
> So you're right, they mean the same thing logically, and only have this
> temporary distinction of WC-1 vs. WC-NG.  In the interest of naming
> clarity, I'll think of a better way.  Maybe:
>  { text_base_abspath, pristine_abspath } - these two will be resolved
> to just one very soon so I'll leave this dual naming for now;
>  { text_base_checksum_md5, pristine_checksum_sha1 } - I'll modify the
> patch before committing it, to make both of these say 'text_base' (or
> perhaps both say 'pristine').
> Good?

Whatever you think best! I've raised my concern...

Received on 2010-04-08 00:44:46 CEST

This is an archived mail posted to the Subversion Dev mailing list.