[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r921848 - /subversion/trunk/subversion/libsvn_wc/adm_ops.c

From: Neels J Hofmeyr <neels_at_elego.de>
Date: Fri, 12 Mar 2010 04:34:36 +0100

Hyrum K. Wright wrote:
>> Hm, I've used this before, always have.
>> IMHO it looks much better this way, and is easier to edit around...
>> I do take care to have the 'else' in the line just above 'if'.
> It's unfortunate if this style has found its way into other places in our codebase.
>> But whatever, if Greg is surprised by it, not many people will be using my
>> way. Will fix, but now it's high time for bed.
> I don't think it's a question of anybody being surprised, or one style is better than another or Greg being the bees-knees or anything like that. Long ago we picked a coding standard, and it just happened to be the "else if (..." style. I'm sure I don't have to enumerate the benefits to being consistent in our style, but suffice it to say it's the way The World is.
> (FWIW, I personally prefer "if (...) {", but we don't do that, either. Old habits die hard.)
> -Hyrum

I said *whatever* already :)

we have boundaries in which style is allowed. wasn't aware that this is such
a catastrophe... will fix and heed. whatever.

This is definitely less confusing and less important than some of our API
docco. :P


Received on 2010-03-12 04:35:23 CET

This is an archived mail posted to the Subversion Dev mailing list.