[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bump minimal APR version

From: Peter Samuelson <peter_at_p12n.org>
Date: Thu, 11 Mar 2010 02:07:27 -0600

[Hyrum K. Wright]
> I'd like to propose that we bump the minimal APR version from the
> current 0.9.7 to something a bit more modern, say 1.3.0.

Only if we drop our "library ABI is compatible all the way back to 1.0"
assertion. At the time Subversion 1.0 was released, I guarantee nobody
built it against apr 1.3. If anybody even built it against apr 1.0,
I'll be surprised.

I don't really have a horse in this race - as Debian maintainer I
switched from apr 0.9 to 1.2 long ago (in such a way as to honor
Debian's own commitment to only change ABIs under strict procedures
that do not require a recompile-every-consumer flag day).

But if we still want to say we support binary compatibility that far
back, well, we can't drop support for apr 0.9.

Peter
Received on 2010-03-11 09:08:04 CET

This is an archived mail posted to the Subversion Dev mailing list.