Daniel Näslund wrote:
> On Mon, Feb 22, 2010 at 12:44:06PM +0100, Neels J Hofmeyr wrote:
>> Re is_dir_empty() comment: When I last created function comments starting
>> with "Helper for..." I was told that that's not really the desired way to
>> go. We should rather have descriptive names / concise docs, and we should
>> design functions to be re-used for a particular purpose, rather than
>> "hiding" code in specialised helper functions. I came to agree with that :)
> Ok. But isn't this bordering to bike-shedding? :)
I thought the same at first, but this one really isn't. Thinking in terms of
helper-functions causes clunky code. Things go together in one function that
are not really that related. They get meaningless names and comments. etc.
Instead thinking "which stock function would do this, and does this stock
function already exist" hopefully saves us a lot of refactoring later.
Nice to see that there will be more versions of this patch :)
* neels waits & watches in anticipation
Received on 2010-02-23 22:57:37 CET