On Thu, Jan 28, 2010 at 07:18:15PM +0100, Daniel Näslund wrote:
> On Thu, Jan 28, 2010 at 06:29:41PM +0100, Stefan Sperling wrote:
> > We could rename it to emit_hunk(), flush_hunk(), hunk_done(), or something
> > similar, signifying that the function is responsible for dealing with
> > a hunk which has been processed.
> > The function itself can figure out what to do with the hunk, based on
> > information in the hunk_info_t, rather than having the caller figure it out.
> Fixed, but with doubts. Passing only hi instead of (hi, n, fuzz) was
> fine but only passing target made it harder to understand why the caller
> calls copy_hunk(). But I've done it so I couldn't have been totally
> against it.
Yes, copy_hunk() is a bad name now that this function does so much
mroe than just copying. Hence my suggestion to rename the function
to something more general.
But that's a trivial change I can make, too. You don't need to post
another revision of this diff. I think it is very good now, thanks! :)
Received on 2010-01-28 19:29:37 CET