[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: tree conflicts with replace

From: Stephen Butler <sbutler_at_elego.de>
Date: Fri, 14 Aug 2009 01:17:00 +0200

Quoting Vincent Lefevre <vincent+svn_at_vinc17.org>:

> Hi,
>
> On 2009-08-13 02:02:42 +0100, Julian Foad wrote:
>> On Thu, 2009-08-13, Neels Janosch Hofmeyr wrote:
>> > [[[
>> > $ svn revert
>> > Reverted 'alpha'
>> > $ svn st
>> > ? alpha
>> > ]]]
>> >
>> > --> Wait, the local changes were both a "delete" and an "add". Only the
>> > "add" got reverted. Is that intended? BASE seems to be in-between
>> the atomic
>> > replace (sorry for the language). That's bad.
>>
>> That's got to be the root of this problem. Sounds like a simple bug. The
>> wierdness that follows it is not surprising, if it leaves the WC in a
>> bad state.
>
> Is this the same bug I've mentioned in my message
>
> svn 1.6.4 bug yields a working copy with missing data
>
> posted yesterday?

Yes.

>
> Is there an issue in the tracker?

I reopened issue 3334 "Tree conflict merry-go-round on update/switch"

   http://subversion.tigris.org/issues/show_bug.cgi?id=3334

Steve

-- 
Stephen Butler | Software Developer
elego Software Solutions GmbH
Gustav-Meyer-Allee 25 | 13355 Berlin | Germany
fon: +49 30 2345 8696 | mobile: +49 163 25 45 015
fax: +49 30 2345 8695 | http://www.elegosoft.com
Geschäftsführer: Olaf Wagner | Sitz der Gesellschaft: Berlin
Amtsgericht Charlottenburg HRB 77719 | USt-IdNr: DE163214194
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=2383469
Received on 2009-08-14 01:17:27 CEST

This is an archived mail posted to the Subversion Dev mailing list.