[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: db-test.c error

From: Paul Burba <ptburba_at_gmail.com>
Date: Wed, 12 Aug 2009 10:44:58 -0400

On Thu, Aug 6, 2009 at 4:13 AM, Edmund Wong<ed_at_kdtc.net> wrote:
> Hi,
>
> With the help of Danielsh on IRC last night, I managed to get
> the build process for SVN on Windows via VSE2008 working.
> There are still a few hiccups that I'm not really sure
> how to fix, but since I can run the tests manually, I'm
> in no hurries to get it fixed.
>
> Incidentally, I managed to get the build process going through
> the following (btw, I removed VSE2008 and installed VS2008,
> but the process shouldn't be different):
>
>    a) I go Danielsh' makefile.pub script.
>    b) I downloaded GnuWin32 exe package
>    c) I downloaded coreutils package (from the same site)
>    d) Installed both programs to install the packages.
>    e) Changed the parameters in the Makefile.Pub to reflect
>       my setup.  (To Danielsh: one tee command had a full path
>       to the tee.exe mentioned,  the other tee command didn't.
>       I changed the c:\misc\bin\tee.exe  to tee.exe.)
>    f) Ran  nmake /F makefile.pub all1
>    g) Ran nmake /F makefile.pub package (manually)
>    h) Ran nmake /F makefile.pub all2    (for the tests)
>    i) Ran "python win-tests.py --cleanup --bin=<targetdir> --debug
>       -f fsfs -c 2>&1 | tee log.win-tests" manually.
>
>
> During make check (i), db-test.c failed.  (nmake /F makefile.pub check
> didn't work (kept on saying it can't make package)), so I needed to
> manually run:
>
> python win-tests.py --cleanup --bin=d:\other_projs\svn\dist --debug
>           -f fsfs -c 2>&1 | tee log.win-tests
>
> Got the following in the log.win-tests:
>
> START: db-test.exe
> PASS:  db-test.exe 1: get information from wc.db
> PASS:  db-test.exe 2: insert different nodes into wc.db
> PASS:  db-test.exe 3: getting the list of BASE or WORKING children
> PASS:  db-test.exe 4: reading information about the WORKING tree
> PASS:  db-test.exe 5: creation of per-directory handles
> PASS:  db-test.exe 6: scanning added working nodes
> PASS:  db-test.exe 7: deletion introspection functions
> PASS:  db-test.exe 8: relocating a node
> ..\..\..\subversion\tests\libsvn_wc\db-test.c:1288: (apr_err=200030)
> ..\..\..\subversion\tests\libsvn_wc\db-test.c:323: (apr_err=200030)
> ..\..\..\subversion\libsvn_subr\sqlite.c:850: (apr_err=200030)
> ..\..\..\subversion\libsvn_subr\sqlite.c:553: (apr_err=200030)
> ..\..\..\subversion\libsvn_wc\wc_db.c:758: (apr_err=200030)
> ..\..\..\subversion\libsvn_subr\sqlite.c:155: (apr_err=200030)
> svn_tests: no such table: conflict_victim
> FAIL:  db-test.exe 9: upgrading to format 13
> db-test.exe: invalid option:
> --srcdir=D:\other_projs\svn\subversion/tests/libsvn_wc
> db-test.exe: invalid option: --http-library=neon
> db-test.exe: invalid option: --bin=d:\other_projs\svn\dist
> END: db-test.exe
>
>
> I did a 'svn upgrade' (no errors) prior to this; yet,
> the db-test.c  test fails.  Am I doing something wrong?
>
> Edmund

Edmund,

FWIW I get a similar error on Windows (VS2008 Version 9.0.21022.8) too:

C:\SVN\src-trunk\Debug\subversion\tests\libsvn_wc>db-test.exe
PASS: db-test.exe 1: get information from wc.db
PASS: db-test.exe 2: insert different nodes into wc.db
PASS: db-test.exe 3: getting the list of BASE or WORKING children
PASS: db-test.exe 4: reading information about the WORKING tree
PASS: db-test.exe 5: creation of per-directory handles
PASS: db-test.exe 6: scanning added working nodes
PASS: db-test.exe 7: deletion introspection functions
PASS: db-test.exe 8: relocating a node
..\..\..\subversion\tests\libsvn_wc\db-test.c:1288: (apr_err=200030)
..\..\..\subversion\tests\libsvn_wc\db-test.c:323: (apr_err=200030)
..\..\..\subversion\libsvn_subr\sqlite.c:850: (apr_err=200030)
..\..\..\subversion\libsvn_subr\sqlite.c:548: (apr_err=200030)
..\..\..\subversion\libsvn_subr\sqlite.c:106: (apr_err=200030)
svn_tests: no such column: incomplete_children
FAIL: db-test.exe 9: upgrading to format 13

C:\SVN\src-trunk\Debug\subversion\tests\libsvn_wc>

Paul

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=2382910
Received on 2009-08-12 16:45:31 CEST

This is an archived mail posted to the Subversion Dev mailing list.