[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svnsync fails with cryptic message

From: <petesea_at_bigfoot.com>
Date: Thu, 21 May 2009 19:32:45 -0700 (PDT)

On Thu, 21 May 2009, B Smith-Mannschott wrote:

> On Sun, May 10, 2009 at 20:31, <petesea_at_bigfoot.com> wrote:
>
>> [...]
>>
>> The Apache error log on the remote mirror shows this:
>>
>>   Could not CHECKOUT resource /path/to/repo/!svn/ver/8410/path/to/directory/in/repository. [409, #0]
>>   Unable to fetch the node revision id of the version resource within the revision. [409, #160013]
>>
>> The odd part is the path in the error message doesn't exist at revision
>> 8410, it was added at revision 8411 (via a tag/copy).
>>
>> [...]
>
> If you have the necessary access, could you check to see if you able to
> dump/load this repository successfully?

I was able to dump and load into a new repository without error.. All
svnadmin commands (dump, create, load) were done with 1.5.5. The
repository contains 9086 revisions and it's 3.7G. The dumpfile is about
7G.

> I ask because I have one repository which I am unable to dump/load
> cleanly because the dump file contains a few nodes in the wrong order
> (it tries to add files to a directory before adding the directory).

I assume svnadmin gave you some kind of error... either during the dump or
load?

Any other suggestions?

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=2352732
Received on 2009-05-22 04:39:42 CEST

This is an archived mail posted to the Subversion Dev mailing list.