[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r37766 - in trunk: . build

From: Stefan Sperling <stsp_at_elego.de>
Date: Mon, 18 May 2009 14:42:15 +0100

On Sun, May 17, 2009 at 04:56:46PM -0700, Arfrever Frehtes Taifersar Arahesis wrote:
> Author: arfrever
> Date: Sun May 17 16:56:46 2009
> New Revision: 37766
>
> Log:
> configure.ac requires Autoconf >=2.58, but build/buildcheck.sh doesn't allow
> Autoconf 2.58, so require Autoconf >=2.59.

That script (which I never used or knew about, it is important?)
seems to require autoconf >= 2.50 expect 2.58.

  ac_version=`${AUTOCONF:-autoconf} --version 2>/dev/null|sed -e 's/^[^0-9]*//' -e 's/[a-z]* *$//' -e 1q`
  if test -z "$ac_version"; then
    echo "buildcheck: autoconf not found."
    echo " You need autoconf version 2.50 or newer installed."
    exit 1
  fi
  
  ...
  
  if test "$ac_version" = "2.58"; then
    echo "buildcheck: autoconf version 2.58 found."
    echo " This version of autoconf is broken. Please install at"
    echo " least autoconf 2.59 or downgrade to version 2.57 which"
    echo " is known to work."
    exit 1
  fi

Why do we really need to drop support for these older versions?

Stefan
Received on 2009-05-18 15:42:39 CEST

This is an archived mail posted to the Subversion Dev mailing list.