[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Bug in svn 1.6.2 configure

From: Dennis <dennis_at_infologika.com.br>
Date: Sun, 17 May 2009 18:36:27 -0300

Dear Sirs

Congratulations for subversion and thank you very much for providing it
to all of us.

I'd like to report a bug, I think my analysis is correct, please read on.

I have apache 2.0.52 along with apr 0.9.17 and apr-util-0.9.15, which
are the right correct versions (and working).

wher I run configure I get:
 error: Apache version incompatible with APR version

Checking around line 7181 of configure I see it seaches for the string:
    AP_SERVER_MINORVERSION_NUMBER
in
    /usr/include/httpd/ap_release.h

but no such string exists. The string that does exist is:
    AP_SERVER_MINORVERSION

and the version number is in quotes: "0"

Pasted bellow is part of the ap_release.h file.

 32 #define AP_SERVER_BASEPRODUCT "Apache"
 33 #define AP_SERVER_MAJORVERSION "2"
 34 #define AP_SERVER_MINORVERSION "0"
 35 #define AP_SERVER_PATCHLEVEL "52"
 36 #define AP_SERVER_MINORREVISION AP_SERVER_MAJORVERSION "."
AP_SERVER_MINORVERSION
 37 #define AP_SERVER_BASEREVISION AP_SERVER_MINORREVISION "."
AP_SERVER_PATCHLEVEL
 38 #define AP_SERVER_BASEVERSION AP_SERVER_BASEPRODUCT "/"
AP_SERVER_BASEREVISION
 39 #define AP_SERVER_VERSION AP_SERVER_BASEVERSION

May be this changed in newer apache versions, but considering apache
2.0.52 configure has 2 flaws:
1) It does not check for the right string
2) It will not accept quotes around the version number

Thank you again,

Dennis Felippa

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=2294373
Received on 2009-05-18 07:37:07 CEST

This is an archived mail posted to the Subversion Dev mailing list.