[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

internal link error under Mac OS X

From: Vincent Lefevre <vincent+svn_at_vinc17.org>
Date: Fri, 1 May 2009 21:46:22 +0200

Any news about the following bug?

  http://trac.macports.org/ticket/18937

I didn't see it mentioned on the Subversion issue tracker and it was
already present in Subversion 1.6.0.

Here's what I get with Subversion 1.6.1:

[...]
/bin/sh /opt/local/var/macports/build/_Users_vinc17_software_dports_devel_subversion/work/subversion-1.6.1/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp -I/opt/local/include/apr-1 -I/opt/local/include/apr-1 -I/opt/local/include -O2 -I./subversion/include -I./subversion -I/opt/local/include/apr-1 -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/include/neon -I/opt/local/include -I/opt/local/include/serf-0 -o subversion/libsvn_fs_util/fs-util.lo -c subversion/libsvn_fs_util/fs-util.c
cd subversion/libsvn_fs_util && /bin/sh /opt/local/var/macports/build/_Users_vinc17_software_dports_devel_subversion/work/subversion-1.6.1/libtool --tag=CC --silent --mode=link /usr/bin/gcc-4.0 -O2 -L/opt/local/lib -L/opt/local/lib/db46 -L/opt/local/lib -L/opt/local/lib -rpath /opt/local/lib -o libsvn_fs_util-1.la fs-util.lo ../../subversion/libsvn_subr/libsvn_subr-1.la /opt/local/lib/libaprutil-1.la -ldb-4.6 -lexpat -liconv /opt/local/lib/libapr-1.la -lpthread -lintl -framework Security -framework CoreFoundation -framework CoreServices
ERROR: No debug map or DWARF data was found to link.cd subversion/libsvn_fs_fs && /bin/sh /opt/local/var/macports/build/_Users_vinc17_software_dports_devel_subversion/work/subversion-1.6.1/libtool --tag=CC --silent --mode=link /usr/bin/gcc-4.0 -O2 -L/opt/local/lib -L/opt/local/lib/db46 -L/opt/local/lib -L/opt/local/lib -rpath /opt/local/lib -o libsvn_fs_fs-1.la caching.lo dag.lo err.lo fs.lo fs_fs.lo id.lo key-gen.lo lock.lo rep-cache.lo tree.lo ../../subversion/libsvn_delta/libsvn_delta-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la /opt/local/lib/libaprutil-1.la -ldb-4.6 -lexpat -liconv /opt/local/lib/libapr-1.la -lpthread ../../subversion/libsvn_fs_util/libsvn_fs_util-1.la -lintl -framework Security -framework CoreFoundation -framework CoreServices
ld: Undefined symbols:
_svn_error__malfunction referenced from libsvn expected to be defined in libsvn
_svn_checksum_ctx_create referenced from libsvn expected to be defined in libsvn
_svn_checksum_final referenced from libsvn expected to be defined in libsvn
_svn_checksum_update referenced from libsvn expected to be defined in libsvn
/usr/bin/libtool: internal link edit command failed
make: *** [subversion/libsvn_fs_fs/libsvn_fs_fs-1.la] Error 1

I don't understand why there's an attempt to link againt libsvn.

I've attached the config.log file and the .la file that have been built.

-- 
Vincent Lefèvre <vincent@vinc17.org> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)




Received on 2009-05-01 21:46:49 CEST

This is an archived mail posted to the Subversion Dev mailing list.