[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Unable to parse reversed revision range

From: Paul Burba <ptburba_at_gmail.com>
Date: Wed, 25 Feb 2009 11:42:14 -0500

On Wed, Jan 28, 2009 at 3:58 PM, Brian Rieck <BRieck_at_sandcherry.com> wrote:
> For efficiency reasons, the system has converted the large body of this message into an attachment.
>
> ---------- Forwarded message ----------
> From: "Brian Rieck" <BRieck_at_sandcherry.com>
> To: "Paul Burba" <ptburba_at_gmail.com>
> Date: Wed, 28 Jan 2009 13:57:36 -0700
> Subject: RE: Re: Unable to parse reversed revision range
> 1) Is this right?  Where is the path separator?
>
> I do not believe this is correct output. I believe that the path separator was stripped somehow in my cut and paste. I see the path separator in the file where I redirected output.
>
> 2) Could you provide the exact command and output of this successful
> merge to 'platform\packagingdistribution\Vivo
> Applications\vmc\WebContent'?
>
> Just for fun I created another branch to do this in.
>
> Output of attempt to merge entire tree:
> ************
> D:\svp_backup>svn merge http://svn-backup/sc/SVP/branches/user_branches/camille
> .\jeff4
> svn: Unable to parse reversed revision range '3-2'
> *************

Hi Brian,

What is the history of
http://svn-backup/sc/SVP/branches/user_branches/camille? Was it
copied directly from trunk or from some other branch?

What about http://svn-backup/sc/SVP/branches/user_branches/jeff4?
From the mergeinfo dump of the repository you provided I see that
there is no mergeinfo on or under trunk, and only empty mergeinfo
within the trees rooted at camille and jeff4. But there are other
branches, e.g.

http://svn-backup/sc/SVP/branches/user_branches/cwall_vmc_090109/platform/packaging/distribution/Vivo
Applications/vmc/WebContent/pages/profilesVocab/updateVocab.xhtml -
/trunk/platform/packaging/distribution/Vivo
Applications/vmc/WebContent/pages/profilesVocab/updateVocab.xhtml:2

that do have explicit mergeinfo and are under the 'problem' directory
of '/platform/packaging/distribution/Vivo'...not a coincidence I
suspect, but I still haven't put together a reproduction.

> Output of just merging the "problem" directory:
> *************
> D:\svp_backup>svn merge "http://svn-backup/sc/SVP/branches/user_branches/camille
> /platform/packaging/distribution/Vivo Applications/vmc/WebContent" ".\jeff4\plat
> form\packaging\distribution\Vivo Applications\vmc\WebContent"
> *************
>
> Second attempt to merge entire tree:
> *************
> D:\svp_backup>svn merge http://svn-backup/sc/SVP/branches/user_branches/camille
> .\jeff4
>
> D:\svp_backup>
> ***************
>
>
> 3) What version of svn do your users use?
>
> They are using 1.5.4. I plan on upgrading to 1.5.5 this week. Should I expect these problems to go away even on branches created with 1.5.4, or should I still see those problems with the "old" branches?

The issue #3067 related problems should go away with 1.5.5 yes, there
are no know issues with that anymore. If you still see this with
1.5.5 let me know, but start another thread.

Paul

> 4) Using svn <= 1.5.5 could you run 'svn pg svn:mergeinfo -R' on the root
> of the repository prior to '7) svn merge <url_to_new_camille_branch>
> <wc_path_to_jeff3>'?

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1227641
Received on 2009-02-25 17:42:34 CET

This is an archived mail posted to the Subversion Dev mailing list.