[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn.collab.net scheduled maintenance downtime

From: David James <james82_at_gmail.com>
Date: Tue, 24 Feb 2009 10:14:02 -0800

On Tue, Feb 24, 2009 at 9:22 AM, Greg Stein <gstein_at_gmail.com> wrote:
> On Tue, Feb 24, 2009 at 18:17, Mark Phippard <markphip_at_gmail.com> wrote:
>> On Tue, Feb 24, 2009 at 12:13 PM, Greg Stein <gstein_at_gmail.com> wrote:
>>> On Tue, Feb 24, 2009 at 18:06, Mark Phippard <markphip_at_gmail.com> wrote:
>>>> On Sat, Feb 21, 2009 at 8:27 PM, Greg Stein <gstein_at_gmail.com> wrote:
>>>>> Some of the commit-hook scripts now require Python 2.4. It isn't
>>>>> needed for end-user building from tarballs. Just for some of the
>>>>> auxilliary tools that we ship.
>>>>>
>>>>> Core svn doesn't need python at all, tho it does need sqlite 3.4 or newer.
>>>>
>>>> We have confirmed that you CANNOT build SVN bindings with Python >
>>>> 2.4.  Here is quote from my build engineer:
>>>
>>> Later than 2.4? Or versions prior?
>>
>> Sorry, I mean Python 2.2.

FWIW, last time I checked, the SWIG Python bindings worked fine with
versions of Python as old as Python 2.2. Have you tried reverting the
changes to find_python.sh so that Python 2.2 is allowed? Maybe it will
just work.

Cheers,

David

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1221773
Received on 2009-02-24 19:15:01 CET

This is an archived mail posted to the Subversion Dev mailing list.