[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn.collab.net scheduled maintenance downtime

From: Mark Phippard <markphip_at_gmail.com>
Date: Tue, 24 Feb 2009 12:17:02 -0500

On Tue, Feb 24, 2009 at 12:13 PM, Greg Stein <gstein_at_gmail.com> wrote:
> On Tue, Feb 24, 2009 at 18:06, Mark Phippard <markphip_at_gmail.com> wrote:
>> On Sat, Feb 21, 2009 at 8:27 PM, Greg Stein <gstein_at_gmail.com> wrote:
>>> Some of the commit-hook scripts now require Python 2.4. It isn't
>>> needed for end-user building from tarballs. Just for some of the
>>> auxilliary tools that we ship.
>>>
>>> Core svn doesn't need python at all, tho it does need sqlite 3.4 or newer.
>>
>> We have confirmed that you CANNOT build SVN bindings with Python >
>> 2.4.  Here is quote from my build engineer:
>
> Later than 2.4? Or versions prior?

Sorry, I mean Python 2.2.

> *Core svn* doesn't need Python. If you want to build Python bindings,
> then yah... you're gonna need Python. As far as the *version* of
> Python... different question. And it looks like the general answer is
> "you need Python 2.4 or later."

Yes, we can build core fine. I am talking about the Python bindings.
We currently support ViewVC on RHEL and of course people want to write
hooks etc. and need bindings.

>> "In the first place, both autogen.sh and configure both checks for Python
>> 2.4 using the build/find_python.sh. If Subversion don't find Python 2.4
>> then configure clearly warns
>> "Python 2.4 or later is required to run the testsuite
>> or to use the Subversion Python bindings"
>>
>> If we continue by fooling configure. Next stop is at 'make swig-py'
>> while compiling  libsvn_swig_py/swigutil_py.c. This is  because of
>> missing 'Py_RETURN_NONE' in python.h."
>
> Eh? I see that symbol in my Python 2.5.

Sorry, should have specifically said 2.2.

>> He mentions autogen.sh but we are not running that, we are just
>> running configure from the tarball.
>>
>> Comments?  Is this what we want?
>
> No... you shouldn't be running autogen.sh.

We are not.

> Did you get your greater/lesser symbol mixed up, above? It is
> *expected* that we're now generally requiring Python 2.4 or later. I
> hadn't thought about the bindings, but it appears they need 2.4 or
> later, too.

I'd like to be able to support RHEL 4, if not RHEL 3, with the bindings.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1221546
Received on 2009-02-24 18:17:20 CET

This is an archived mail posted to the Subversion Dev mailing list.