[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: copy with --parents creates bogus folder

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Fri, 20 Feb 2009 23:45:53 +0200 (Jerusalem Standard Time)

Was this looked into? Fixed? Filed to the tracker?

Stefan Küng wrote on Thu, 8 Jan 2009 at 18:39 +0100:
> Hi,
>
> To reproduce, first create empty repository, served via apache. Then:
>
> svn mkdir http://server/trunk/F%c3%b6lder -m "create folder with non-ascii
> char in name"
>
> svn co http://server/trunk wc
> echo dummy > wc\föle.txt
> svn add wc\föle.txt
> svn ci wc -m "add file with non-ascii char in name"
> svn cp http://server/trunk/f%c3%b6le.txt http://server/trunk/F%c3%b6lder/f%c3%b6le.txt
> --parents -m "copy file"
> svn list http://server/trunk
> Földer
> F%C3%B6lder
> föle.txt
>
>
> What I would expect is that the file "föle.txt" is copied to the
> existing folder "Földer", but what actually happens is that a new folder
> is created with name "F%C3%B6lder".
>
>
> This happens both with 1.5.x and a trunk build.
>
> Note: I don't think the cause is the url escaping in the command line
> client, since the same happens in TSVN where I just checked that the
> urls are passed to svn_client_copy properly escaped.
>
> Stefan
>
>

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1200675
Received on 2009-02-20 23:26:51 CET

This is an archived mail posted to the Subversion Dev mailing list.