[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Segfault in ruby tests

From: Joe Swatosh <joe.swatosh_at_gmail.com>
Date: Tue, 27 Jan 2009 20:41:59 -0800

Howdy Hyrum,

On Tue, Jan 27, 2009 at 9:57 AM, Hyrum K. Wright
<hyrum_wright_at_mail.utexas.edu> wrote:
> Joe, Kou,
> The ruby bindings tests are segfaulting on the buildbot. I can reproduce
> locally:
>
> [[[
> hwright_at_orac:~/dev/svn-trunk$ make check-swig-rb
> cd /home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby; \
> /usr/bin/ruby -I
> /home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby \
>
> /home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/test/run-test.rb
> \
> --verbose=normal
> Loaded suite .
> Started
> .................................................................................................................../home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/svn/util.rb:86:
> [BUG] Segmentation fault
> ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux]
>
> /bin/bash: line 3: 17077 Aborted /usr/bin/ruby -I
> /home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby
> /home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/test/run-test.rb
> --verbose=normal
> make: *** [check-swig-rb] Error 134
> hwright_at_orac:~/dev/svn-trunk$
> ]]]
>
> This is, of course, a blocker for branching 1.6.x.
>

I cannot reproduce at r35519.

--
Joe Swatosh
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1061706
Received on 2009-01-28 05:42:51 CET

This is an archived mail posted to the Subversion Dev mailing list.