[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r35465 - in trunk/subversion: include libsvn_client libsvn_subr libsvn_wc

From: Greg Stein <gstein_at_gmail.com>
Date: Mon, 26 Jan 2009 15:29:54 +0100

On Mon, Jan 26, 2009 at 15:07, Bert Huijben <rhuijben_at_sharpsvn.net> wrote:
>> -----Original Message-----
>> From: Greg Stein [mailto:gstein_at_gmail.com]
>> Sent: maandag 26 januari 2009 12:31
>> To: svn_at_subversion.tigris.org
>> Subject: svn commit: r35465 - in trunk/subversion: include
>> libsvn_client libsvn_subr libsvn_wc
>>
>> Author: gstein
>> Date: Mon Jan 26 03:30:42 2009
>> New Revision: 35465
>>
>> Log:
>> Various cleanups after all the subst work.
>>
>> * subversion/include/svn_subst.h:
>> (SVN_SUBST_NATIVE_EOL_STR): new definition for the EOL format used in
>> the repository ("Normal Form")
>
> Greg,
>
> I think we should use 'NORMAL', 'INTERNAL' or [Fill-in-your-bike shed] for
> the NATIVE part of this macro.
>
> The subst methods can be used to convert to eols to svn:eol-style 'native'
> format ('\r\n' on Windows) and this #define doesn't make it 100% obvious
> that this value is for something completely different (Our internal format).

At first, I had it called SVN_SUBST_NORMAL_FORM_EOL, but pretty much
every use looked like this:

  if (eol_style == svn_subst_eol_style_native)
    eol_str = SVN_SUBST_NORMAL_FORM_EOL;

The native/NORMAL clashed, so I renamed it to SVN_SUBST_NATIVE_EOL_STR.

How about the name SVN_SUBST_REPOSITORY_EOL_STR?

Cheers,
-g

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1054846
Received on 2009-01-26 15:30:16 CET

This is an archived mail posted to the Subversion Dev mailing list.