[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r35273 - trunk/tools/dist

From: Hyrum K. Wright <hyrum_wright_at_mail.utexas.edu>
Date: Fri, 16 Jan 2009 12:20:18 -0600

Greg Stein wrote:
> On Fri, Jan 16, 2009 at 19:01, Hyrum K. Wright
> <hyrum_wright_at_mail.utexas.edu> wrote:
>> ...
>>> Did you mean 3.6.9, because the previous amalgamation's were with that version.
>> No, I meant 3.5.9. That's currently the version we recommend, though we require
>> only 3.4.0.
>>
>> If we want to bump to a more recent version, we'll need to update configure as
>> well as the above.
>
> Yeah, I think it is time to go ahead and bump to 3.6.10. When we first
> added sqlite, the 3.6.x series did not have the phrase "and ready for
> production use" in any of their NEWS entries. They've since added
> that, so I think we're safe to bump.

Bump recommended or minimum? I don't think that we *require* anything in the
most recent versions, so I don't know think we need to bump the minimum required
version. +1 to an updated recommended version, though.

>>> BTW, 3.6.10 is out that fixes an issue that can lead to database corruption:
>>>
>>> http://www.sqlite.org/releaselog/3_6_10.html
>
> Interesting to note that they fixed Ticket 3512 -- the ENOTSUP problem
> we ran into. So 3.6.10 should have that fix already!

Yay! Perhaps Stefan can test it for us.

-Hyrum

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1029332
Received on 2009-01-16 19:20:36 CET

This is an archived mail posted to the Subversion Dev mailing list.