[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: RFC: Change minimum Python requirement to 2.?

From: Stefan Sperling <stsp_at_elego.de>
Date: Tue, 13 Jan 2009 22:32:26 +0000

On Tue, Jan 13, 2009 at 02:20:52PM -0800, Justin Erenkrantz wrote:
> However,
> I think it's completely fair to say that in order to run the test
> suites for Subversion 1.6+, you are required to use Python 2.4+.

Yes.

> If you're running the test suites, welcome - you're now a developer. =)

Not necessarily. Some packaging systems offer the opportunity to run
regression tests as part of the package build. OpenBSD has a 'make
regress' target in the ports tree, for example, and the subversion port
makes use of it. It's a nice way of smoke-testing a freshly compiled set
of binaries.

Stefan
Received on 2009-01-13 23:33:27 CET

This is an archived mail posted to the Subversion Dev mailing list.