[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r35213 - in trunk/subversion: include libsvn_client

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: Tue, 13 Jan 2009 18:13:33 +0000

Greg Stein wrote:
> It does kind of suck that the field names end in 64. The undecorated
> form is preferable, but (sigh) used by the incorrect stuff...

We could name them "file_size" and "working_file_size" (instead of
"size64" and "working_size64"). That would be good in its own right
because the info struct doesn't always apply to a file and this would
make it clear that these fields only apply to a file.

> On Tue, Jan 13, 2009 at 09:35, Bert Huijben <rhuijben_at_sharpsvn.net> wrote:
> > Author: rhuijben
> > Date: Tue Jan 13 09:35:23 2009
> > New Revision: 35213
> >
> > Log:
> > Following up on r35191 and r35207, use svn_filesize_t for the 64 bit filesizes
> > in svn_info_t.

Cool. Thanks, Bert.

- Julian

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1022580
Received on 2009-01-13 19:14:00 CET

This is an archived mail posted to the Subversion Dev mailing list.