[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Status of 1.6

From: Eric Gillespie <epg_at_pretzelnet.org>
Date: Tue, 06 Jan 2009 10:37:52 -0800

Hyrum K. Wright <hyrum_wright_at_mail.utexas.edu> writes:

> As far as requiring "such a recent version" of SQLite, we
> currently require 3.4.0 or above, which was released on June
> 18, 2007. I'm of the opinion that if a user wants to install a
> new version of Subversion, they may have to install newer
> versions of the dependencies. Hopefully packagers are
> sensitive to this fact as well, and will provide ways to get
> those dependencies.

This is not acceptable. You can't think in terms of upstream
releases, but when they filter into the systems that people use.

RHEL 4 supported until 2012 ships sqlite 3.3.6
RHEL 5 supported until 2014 ships sqlite 3.3.6

If you really, really, *must have* 3.4, then you need to ship
sqlite in the deps tar file and make it Just Work as we have done
with apr (though note we support RHEL4's apr (0.9) just fine...).

You can't just wave your hands and say "Subversion packagers will
take care of it". Packagers are rarely as competent as the
developers actually working on the package. It's neither unusual
nor unreasonable to trust Red Hat and Subversion but not Joe Bob
RPM Guy.

-- 
Eric Gillespie <*> epg_at_pretzelnet.org
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1008191
Received on 2009-01-06 19:39:02 CET

This is an archived mail posted to the Subversion Dev mailing list.