[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Error when creating tags from working copy

From: Karl Fogel <kfogel_at_red-bean.com>
Date: Tue, 30 Dec 2008 11:05:01 -0500

Daniel Shahaf <d.s_at_daniel.shahaf.name> writes:
> Karl, is this bug still open? And how many bugs are there here (bug in
> mod_dav_svn? bug in the fs layer?)?
>
> I'd like to file an issue for it, at least, but I'm not sure I'll describe
> it correctly. Could you do that?

As far as I know, it's still open. A good summary would be:

   "txn wrongly claims file exists (over http:// only)"

(The tag-creation error is just one side effect of that underlying bug.)

The relevant emails are:

   Michael Susser's original post:
     http://svn.haxx.se/users/archive-2008-10/0312.shtml

   My initial response, with reproduction script:
     http://svn.haxx.se/users/archive-2008-10/0352.shtml

   Mail in which I noted a separate, possibly unrelated problem:
     http://svn.haxx.se/users/archive-2008-10/0355.shtml

   Mail in which I dig deep into mod_dav (anyone debugging the main
   problem will want to read this mail carefully):
     http://svn.haxx.se/users/archive-2008-10/0357.shtml

I'd like to file an issue for it, but I don't have time right now to
check whether #3119 is already the right issue or whether we need a new
one. The above list is to enable someone else to do that if they want;
I wish I could guarantee more, but can't.

-Karl

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=996060
Received on 2008-12-30 17:07:15 CET

This is an archived mail posted to the Subversion Dev mailing list.