[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [construct-rolling-environment.sh] Versions of Subversion dependencies in subversion-deps-1.6.*

From: Kouhei Sutou <kou_at_cozmixng.org>
Date: Sun, 21 Dec 2008 12:17:16 +0900 (JST)

Hi,

In <200812202353.35546.Arfrever.FTA_at_gmail.com>
  "Re: [construct-rolling-environment.sh] Versions of Subversion dependencies in subversion-deps-1.6.*" on Sat, 20 Dec 2008 23:53:35 +0100,
  Arfrever Frehtes Taifersar Arahesis <Arfrever.FTA_at_GMail.Com> wrote:

> 2008-12-15 07:37:21 Joe Swatosh napisał(a):
> > On Sun, Dec 14, 2008 at 9:41 AM, Arfrever Frehtes Taifersar Arahesis
> > <arfrever.fta_at_gmail.com> wrote:
> > > 2008-11-30 05:13:18 Hyrum K. Wright napisał(a):
> > >> Arfrever Frehtes Taifersar Arahesis wrote:
> > >> > I would like to suggest to include updated versions of some Subversion
> > >> > dependencies in subversion-deps-1.6.*.
> > >> >
> > >> > APR: 1.2.12 => 1.3.3
> > >> > APR-Util: 1.2.12 => 1.3.4
> > >> > Apache HTTPD: 2.2.9 => 2.2.10
> > >>
> > >> I think these are all acceptable changes.
> > >>
> > >> > SWIG: 1.3.31 => 1.3.36
> > >> > Today I ran `make check-swig-{pl,py,rb}` [*] with SWIG 1.3.31 and 1.3.36 and
> > >> > there wasn't any additional failure with SWIG 1.3.36.
> > >> > (2 errors + 2 failures during `make check-swig-rb`)
> > >> >
> > >> > [*] Tested with Subversion trunk r34469, Python 2.6, Perl 5.10.0 and Ruby 1.8.6_p287.
> > >>
> > >> I'm not so sure about this one. We currently claim to support swig versions up
> > >> to 1.3.31. If we change the swig which we build the bindings with, we should
> > >> change the swig we publicly claim to support. I'll let people more
> > >> knowledgeable about the swig bindings than myself make the decision about which
> > >> swig versions we should support, but -1 to shipping with a swig we don't support.
> > >
> > > Kouhei Sutou, Chia-liang Kao, Joe Swatosh:
> > > Do you know any problems with SWIG 1.3.36?
> > >
> > > --
> > > Arfrever Frehtes Taifersar Arahesis
> > >
> >
> > Highest version I've tried is 1.3.33. If I can find time I'll try
> > 1.3.36 (definitely no promises of timeliness though).
>
> Ping.

I'm using 1.3.36 for the Ruby bindings but it seems that it
doesn't have problems.

Thanks,

--
kou
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=988670
Received on 2008-12-21 04:17:40 CET

This is an archived mail posted to the Subversion Dev mailing list.