[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r33413 - in trunk/subversion: include libsvn_subr tests/libsvn_subr

From: Lieven Govaerts <svnlgo_at_mobsol.be>
Date: Wed, 08 Oct 2008 18:10:58 +0200

Karl Fogel wrote:
> lgo_at_tigris.org writes:

>>
>> const char *
>> +svn_uri_canonicalize(const char *uri, apr_pool_t *pool)
>> +{
>> + return canonicalize(URI, uri, pool);;
>> +}
>
> I realize it's not part of this commit, but the aliasing of TRUE and
> FALSE to potentially non-binary values strikes me as a bad idea. If
> we're going to have symbolic names DIRENT and URI, could we at least
> make them enums, or named integer constants, or something?
>
> I'm talking about this part at the beginning of the file:
>
> /* Labels for some commonly used constants */
> #define URI TRUE
> #define DIRENT FALSE

Switched to an enum in r33553.

Lieven

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-10-08 18:10:43 CEST

This is an archived mail posted to the Subversion Dev mailing list.